Jumat, 08 Juni 2012
Jurnal Kribas Hernanda S. P 2011 4350 1175
JURNAL KOMUNIKASI DATA
“PROTOKOL”
Di buat oleh : Kribas Hernanda S.P
Kelas : 2 X.O
NPM : 201143501175
E-mail : hatake_ibas@yahoo.com
Dosen : Pak Nahot Frastian, S.Kom
Abstrak
Model OSI menyediakan secara konseptual kerangka kerja untuk komunikasi antar computer, tetapi model ini bukan merupakan metode komunikasi. Sebenarnya komunikasi dapat terjadi menggunakan protocol komunikasi. Di dalam konteks jaringan data, sebuah protocol adalah suatu aturan formal dan kesepakatan yang menentukan bagaimana computer bertukar informasi melewati sebuah media jaringan. Sebuah protocol mengimplementasikan BAB salah satu atau lebih dari lapisan – lapisan OSI. Sebuah variasi yang lebar dari adanya protocol komunikasi, tetapi semua memelihara pada salah satu aliran group: protocol LAN, protocol WAN, protocol jaringan dan protocol routing.
Pendahuluan - Protocol LAN beroprasi pada lapisan fisik dan data link dari model OSI serta mendefinisikan komunikasi dari macam – macam media LAN. Protocol WAN beroprasi pada ketiga lapisan terbawah dari model OSI dan mendifinisikan dari macam – macam WAN. Protocol routing adalah protocol lapisan jaringan yang bertanggung jawab untuk menentukan jalan dan pengaturan lalu lintas. Akhirnya protocol jaringan terdiri dari berbagai protocol dari lapisan teratas yang ada dalam sederetan protocol.
A. Definisi Protocol
Protocol adalah sekumpulan peraturan atau perjanjian yang menentukan format dan transimi data. Layer n disebuah computer akan berkomunikasi dengan layer n di computer n yang lain.Peraturan dan perjanjian yang di pergunakan dalam komunikasi ini sering di sebut dengan protocol layer n.Selain itu protokol juga berfungsi untuk memungkinkan dua atau lebih komputer dapat berkomunikasi dengan bahasa yang sama.
Hal – hal yang harus dipehatikan dalam protokol adalah sebagai berikut:
- Syntax, merupakan format data dan cara pengkodean yang digunakan untuk mengkodekan sinyal.
- Semantix, digunakan untuk mengetahui maksud dari infomasi yang dikirim dan mengoreksi kesalahan yang terjadi dari informasi tadi.
- Timing, digunakan untuk mengetahui kecepatan transmisi data. Selama dua decade terakhir,terjadi peningkatan besar dalam jumlah dan ukuran jaringan computer(network).Banyak diantara network- network ini dibangun berdasarkan implementasi software dan hardware yang berbeda.Sebagai hasilnya,mereka menjadi incompatible dan sulit berhubungan antara satu dengan yang lain.Untuk mengatasi masalah ini,International Organization for Standarization(ISO)meneliti berbagai pola network. ISO menemukan bahwa terdapat kebutuhan untuk menciptakan sebuah model network yang dapat berkomunikasi dan memiliki kemampuan interoperabilyti sehingga dikeluarkannya model referensi OSI pada tahun 1984. Agar paket data dapat berjalan dari sumber tujuan dalam sebuah jaringan,maka diperlukan adanya sebuah bahasa yang di mengerti oleh semua device jaringan atau sebuah protocol.
Untuk mengatasi masalah ketidaksesuaian dalam sebuah jaringan,yang membuat jaringan tidak dapat berkomunikasi satu dengan yang lain, International Organization for Standarization(ISO) melaukan riset dalam beberapa pola jaringan seperti DECNET,SNA,dan TCP/IP untuk membuat sekumpulan peraturan. Sebagai hsil dari riset ini,iso membuat sebuah model jaringan yang membantu vendor-vendor dalam menciptakan jaringan yang kompatibel dan dapat beroperasi dengan jaringan yang lain.Model referensi OSI(open system interconection) dikeluarkan pada tahun 1984,memberikan standard bagi para vendor untuk memastikan terjaminnya interooerabilitas dan kompatibilitas antar berbagai teknologi jaringan yang di produksi oleh berbagai macam perusahaan di seluruh dunia dan dibawah gambar Protokol.
B. Standarisasi Protokol
Agar protokol dapat dipakai untuk komunikasi diberbagai pembuat perangkat maka dibutuhkan standardisasi protokol. Banyak lembaga dunia yang bekerja untuk standardisasi protokol. Yang saat ini banyak mengeluarkan standardisasi protokol yaitu IETF, ETSI, ITU, dan ANSIProtokol adalah sebuah aturan atau standar yang mengatur atau mengijinkan terjadinya hubungan, komunikasi, dan perpindahan data antara dua atau lebih titik komputer. Protokol dapat diterapkan pada perangkat keras, perangkat lunak atau kombinasi dari keduanya. Pada tingkatan yang terendah, protokol mendefinisikan koneksi perangkat keras. Protocol digunakan untuk menentukan jenis layanan yang akan dilakukan pada internet.
TCP/IP (singkatan dari Transmission Control Protocol/Internet Protocol)
Adalah standar komunikasi data yang digunakan oleh komunitas internet dalam proses tukar-menukar data dari satu komputer ke komputer lain di dalam jaringan Internet. Protokol ini tidaklah dapat berdiri sendiri, karena memang protokol ini berupa kumpulan protokol (protocol suite). Protokol ini juga merupakan protokol yang paling banyak digunakan saat ini. Data tersebut diimplementasikan dalam bentuk perangkat lunak (software) di sistem operasi. Istilah yang diberikan kepada perangkat lunak ini adalah TCP/IP stack
Protokol TCP/IP dikembangkan pada akhir dekade 1970-an hingga awal 1980-an sebagai sebuah protokol standar untuk menghubungkan komputer-komputer dan jaringan untuk membentuk sebuah jaringan yang luas (WAN). TCP/IP merupakan sebuah standar jaringan terbuka yang bersifat independen terhadap mekanisme transport jaringan fisik yang digunakan, sehingga dapat digunakan di mana saja. Protokol ini menggunakan skema pengalamatan yang sederhana yang disebut sebagai alamat IP (IP Address) yang mengizinkan hingga beberapa ratus juta komputer untuk dapat saling berhubungan satu sama lainnya di Internet. Protokol ini juga bersifat routable yang berarti protokol ini cocok untuk menghubungkan sistem-sistem berbeda (seperti Microsoft Windows dan keluarga UNIX) untuk membentuk jaringan yang heterogen.
Protokol TCP/IP selalu berevolusi seiring dengan waktu, mengingat semakin banyaknya kebutuhan terhadap jaringan komputer dan Internet. Pengembangan ini dilakukan oleh beberapa badan, seperti halnya Internet Society (ISOC), Internet Architecture Board (IAB), dan Internet Engineering Task Force (IETF). Macam-macam protokol yang berjalan di atas TCP/IP, skema pengalamatan, dan konsep TCP/IP didefinisikan dalam dokumen yang disebut sebagai Request for Comments (RFC) yang dikeluarkan oleh IETF.
Protokol Komunikasi TCP/IP Pada TCP/IP terdapat beberapa protokol sub yang menangani masalah komunikasi antar komputer. TCP/IP merngimplemenasikan arsitektur berlapis yang terdiri atas empat lapis, diantaranya adalah :
1. Protokol lapisan aplikasi : bertanggung jawab untuk menyediakan akses kepada aplikasi terhadap layanan jaringan TCP/IP. Protokol ini mencakup protokol Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet, Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol (SNMP), dan masih banyak protokol lainnya. Dalam beberapa implementasi stack protokol, seperti halnya Microsoft TCP/IP, protokol-protokol lapisan aplikasi berinteraksi dengan menggunakan antarmuka Windows Sockets (Winsock) atau NetBIOS over TCP/IP (NetBT).
2. Protokol lapisan antar-host : berguna untuk membuat komunikasi menggunakan sesi koneksi yang bersifat connection-oriented atau broadcast yang bersifat connectionless. Protokol dalam lapisan ini adalah Transmission Control Protocol (TCP) dan User Datagram Protocol (UDP). 3. Protokol lapisan internetwork : bertanggung jawab untuk melakukan pemetaan (routing) dan enkapsulasi paket-paket data jaringan menjadi paket-paket IP. Protokol yang bekerja dalam lapisan ini adalah Internet Protocol (IP), Address Resolution Protocol (ARP), Internet Control Message Protocol (ICMP), dan Internet Group Management Protocol (IGMP). 4. Protokol lapisan antarmuka jaringan : bertanggung jawab untuk meletakkan frame-frame jaringan di atas media jaringan yang digunakan. TCP/IP dapat bekerja dengan banyak teknologi transport, mulai dari teknologi transport dalam LAN (seperti halnya Ethernet dan Token Ring), MAN dan WAN (seperti halnya dial-up modem yang berjalan di atas Public Switched Telephone Network (PSTN), Integrated Services Digital Network (ISDN), serta Asynchronous Transfer Mode (ATM))
UDP ( User Datagram Protokol) UDP, singkatan dari User Datagram Protocol, adalah salah satu protokol lapisan transpor TCP/IP yang mendukung komunikasi yang tidak andal (unreliable), tanpa koneksi (connectionless) antara host-host dalam jaringan yang menggunakan TCP/IP. Protokol ini didefinisikan dalam RFC 768.
UDP memiliki karakteristik-karakteristik berikut:
Connectionless (tanpa koneksi): Pesan-pesan UDP akan dikirimkan tanpa harus dilakukan proses negosiasi koneksi antara dua host yang hendak berukar informasi.
Unreliable (tidak andal): Pesan-pesan UDP akan dikirimkan sebagai datagram tanpa adanya nomor urut atau pesan acknowledgment. Protokol lapisan aplikasi yang berjalan di atas UDP harus melakukan pemulihan terhadap pesan-pesan yang hilang selama transmisi. Umumnya, protokol lapisan aplikasi yang berjalan di atas UDP mengimplementasikan layanan keandalan mereka masing-masing, atau mengirim pesan secara periodik atau dengan menggunakan waktu yang telah didefinisikan.
UDP menyediakan mekanisme untuk mengirim pesan-pesan ke sebuah protokol lapisan aplikasi atau proses tertentu di dalam sebuah host dalam jaringan yang menggunakan TCP/IP. Header UDP berisi field Source Process Identification dan Destination Process Identification.
UDP menyediakan penghitungan checksum berukuran 16-bit terhadap keseluruhan pesan UDP.
UDP tidak menyediakan layanan-layanan antar-host berikut:
UDP tidak menyediakan mekanisme penyanggaan (buffering) dari data yang masuk ataupun data yang keluar. Tugas buffering merupakan tugas yang harus diimplementasikan oleh protokol lapisan aplikasi yang berjalan di atas UDP.
UDP tidak menyediakan mekanisme segmentasi data yang besar ke dalam segmen-segmen data, seperti yang terjadi dalam protokol TCP. Karena itulah, protokol lapisan aplikasi yang berjalan di atas UDP harus mengirimkan data yang berukuran kecil (tidak lebih besar dari nilai Maximum Transfer Unit/MTU) yang dimiliki oleh sebuah antarmuka di mana data tersebut dikirim. Karena, jika ukuran paket data yang dikirim lebih besar dibandingkan nilai MTU, paket data yang dikirimkan bisa saja terpecah menjadi beberapa fragmen yang akhirnya tidak jadi terkirim dengan benar.
UDP tidak menyediakan mekanisme flow-control, seperti yang dimiliki oleh TCP.
PENGGUNAAN UDP UDP sering digunakan dalam beberapa tugas berikut:
Protokol yang “ringan” (lightweight): Untuk menghemat sumber daya memori dan prosesor, beberapa protokol lapisan aplikasi membutuhkan penggunaan protokol yang ringan yang dapat melakukan fungsi-fungsi spesifik dengan saling bertukar pesan. Contoh dari protokol yang ringan adalah fungsi query nama dalam protokol lapisan aplikasi Domain Name System.
Protokol lapisan aplikasi yang mengimplementasikan layanan keandalan: Jika protokol lapisan aplikasi menyediakan layanan transfer data yang andal, maka kebutuhan terhadap keandalan yang ditawarkan oleh TCP pun menjadi tidak ada. Contoh dari protokol seperti ini adalah Trivial File Transfer Protocol (TFTP) dan Network File System (NFS)
Protokol yang tidak membutuhkan keandalan. Contoh protokol ini adalah protokol Routing Information Protocol (RIP).
Transmisi broadcast: Karena UDP merupakan protokol yang tidak perlu membuat koneksi terlebih dahulu dengan sebuah host tertentu, maka transmisi broadcast pun dimungkinkan. Sebuah protokol lapisan aplikasi dapat mengirimkan paket data ke beberapa tujuan dengan menggunakan alamat multicast atau broadcast. Hal ini kontras dengan protokol TCP yang hanya dapat mengirimkan transmisi one-to-one. Contoh: query nama dalam protokol NetBIOS Name Service.
PESAN UDP UDP, berbeda dengan TCP yang memiliki satuan paket data yang disebut dengan segmen, melakukan pengepakan terhadap data ke dalam pesan-pesan UDP (UDP Messages). Sebuah pesan UDP berisi header UDP dan akan dikirimkan ke protokol lapisan selanjutnya (lapisan internetwork) setelah mengepaknya menjadi datagram IP. Enkapsulasi terhadap pesan-pesan UDP oleh protokol IP dilakukan dengan menambahkan header IP dengan protokol IP nomor 17 (0×11). Pesan UDP dapat memiliki besar maksimum 65507 byte: 65535 (216)-20 (ukuran terkecil dari header IP)-8 (ukuran dari header UDP) byte. Datagram IP yang dihasilkan dari proses enkapsulasi tersebut, akan dienkapsulasi kembali dengan menggunakan header dan trailer protokol lapisan Network Interface yang digunakan oleh host tersebut.
Dalam header IP dari sebuah pesan UDP, field Source IP Address akan diset ke antarmuka host yang mengirimkan pesan UDP yang bersangkutan; sementara field Destination IP Address akan diset ke alamat IP unicast dari sebuah host tertentu, alamat IP broadcast, atau alamat IP multicast.
PORT UDP Seperti halnya TCP, UDP juga memiliki saluran untuk mengirimkan informasi antar host, yang disebut dengan UDP Port. Untuk menggunakan protokol UDP, sebuah aplikasi harus menyediakan alamat IP dan nomor UDP Port dari host yang dituju. Sebuah UDP port berfungsi sebagai sebuah multiplexed message queue, yang berarti bahwa UDP port tersebut dapat menerima beberapa pesan secara sekaligus. Setiap port diidentifikasi dengan nomor yang unik, seperti halnya TCP, tetapi meskipun begitu, UDP Port berbeda dengan TCP Port meskipun memiliki nomor port yang sama. Tabel di bawah ini mendaftarkan beberapa UDP port yang telah dikenal secara luas.
Nomor Port UDP Digunakan oleh 53 Domain Name System (DNS) Name Query 67 BOOTP client (Dynamic Host Configuration Protocol [DHCP]) 68 BOOTP server (DHCP) 69 Trivial File Transfer Protocol (TFTP) 137 NetBIOS Name Service 138 NetBIOS Datagram Service 161 Simple Network Management Protocol (SNMP) 445 Server Message Block (SMB) 520 Routing Information Protocol (RIP) 1812/1813 Remote Authentication Dial-In User Service (RADIUS)
Domain Name System (DNS) Domain Name System (DNS) adalah distribute database system yang digunakan untuk pencarian nama komputer (name resolution) di jaringan yang mengunakan TCP/IP (Transmission Control Protocol/Internet Protocol). DNS biasa digunakan pada aplikasi yang terhubung ke Internet seperti web browser atau e-mail, dimana DNS membantu memetakan host name sebuah komputer ke IP address. Selain digunakan di Internet, DNS juga dapat di implementasikan ke private network atau intranet dimana DNS memiliki keunggulan seperti: 1. Mudah, DNS sangat mudah karena user tidak lagi direpotkan untuk mengingat IP address sebuah komputer cukup host name (nama Komputer). 2. Konsisten, IP address sebuah komputer bisa berubah tapi host name tidak berubah. 3. Simple, user hanya menggunakan satu nama domain untuk mencari baik di Internet maupun di Intranet.
Struktur DNS Domain Name Space merupakan sebuah hirarki pengelompokan domain berdasarkan nama, yang terbagi menjadi beberapa bagian diantaranya:
Root-Level Domains Domain ditentukan berdasarkan tingkatan kemampuan yang ada di struktur hirarki yang disebut dengan level. Level paling atas di hirarki disebut dengan root domain. Root domain di ekspresikan berdasarkan periode dimana lambang untuk root domain adalah (“.”).
Top-Level Domains Pada bagian dibawah ini adalah contoh dari top-level domains: a) .com Organisasi Komersial b) .edu Institusi pendidikan atau universitas c) .org Organisasi non-profit d) .net Networks (backbone Internet) e) .gov Organisasi pemerintah non militer f) .mil Organisasi pemerintah militer g) .num No telpon h) .arpa Reverse DNS i) .xx dua-huruf untuk kode Negara (id:indonesia.my:malaysia,au:australia)
Top-level domains dapat berisi second-level domains dan hosts.
Second-Level Domains Second-level domains dapat berisi host dan domain lain, yang disebut dengan subdomain. Untuk contoh: Domain Bujangan, bujangan.com terdapat komputer (host) seperti server1.bujangan.com dan subdomain training.bujangan.com. Subdomain training.bujangan.com juga terdapat komputer (host) seperti client1.training.bujangan.com.
Host Names Domain name yang digunakan dengan host name akan menciptakan fully qualified domain name (FQDN) untuk setiap komputer. Sebagai contoh, jika terdapat fileserver1.detik.com, dimana fileserver1 adalah host name dan detik.com adalah domain name.
Bagaimana DNS Bekerja Fungsi dari DNS adalah menerjemahkan nama komputer ke IP address (memetakan). Client DNS disebut dengan resolvers dan DNS server disebut dengan name servers. Resolvers atau client mengirimkan permintaan ke name server berupa queries. Name server akan memproses dengan cara mencek ke local database DNS, menghubungi name server lainnya atau akan mengirimkan message failure jika ternyata permintaan dari client tidak ditemukan. Proses tersebut disebut dengan Forward Lookup Query, yaitu permintaan dari client dengan cara memetakan nama komputer (host) ke IP address.
Cara kerja Domain Name Sistem
a) Resolvers mengirimkan queries ke name server b) Name server mencek ke local database, atau menghubungi name server lainnya, jika ditemukan akan diberitahukan ke resolvers jika tidak akan mengirimkan failure message c) Resolvers menghubungi host yang dituju dengan menggunakan IP address yang diberikan name server
Point-to-Point Protocol
Point-to-Point Protocol (sering disingkat menjadi PPP) adalah sebuah protokol enkapsulasi paket jaringan yang banyak digunakan pada wide area network (WAN). Protokol ini merupakan standar industri yang berjalan pada lapisan data-link dan dikembangkan pada awal tahun 1990-an sebagai respons terhadap masalah-masalah yang terjadi pada protokol Serial Line Internet Protocol (SLIP), yang hanya mendukung pengalamatan IP statis kepada para kliennya. Dibandingkan dengan pendahulunya (SLIP), PPP jauh lebih baik, mengingat kerja protokol ini lebih cepat, menawarkan koreksi kesalahan, dan negosiasi sesi secara dinamis tanpa adanya intervensi dari pengguna. Selain itu, protokol ini juga mendukung banyak protokol-protokol jaringan secara simultan. PPP didefinisikan pada RFC 1661 dan RFC 1662.
Serial Line Internet Protocol
Serial Line Internet Protocol dianggap berkaitan erat dengan pengertian berikut Disingkat dengan SLIP. Sebuah protokol yang memungkinkan pemindahan data IP melalui saluran telepon. Alat bantu lainnya dalam SLIP adalah PPP yang mendeteksi kesalahan dan konfigurasi. Sistem ini memerlukan satu komputer server sebagai penampungnya, dan secara perlahan-lahan akan digantikan oleh standar PPP yang memiliki kecepatan proses lebih tinggi.
Internet Control Message Protocol (ICMP)
adalah salah satu protokol inti dari keluarga. ICMP berbeda tujuan dengan TCP dan UDP dalam hal ICMP tidak digunakan secara langsung oleh aplikasi jaringan milik pengguna. salah satu pengecualian adalah aplikasi ping yang mengirim pesan ICMP Echo Request (dan menerima Echo Reply) untuk menentukan apakah komputer tujuan dapat dijangkau dan berapa lama paket yang dikirimkan dibalas oleh komputer tujuan. protokol internet. ICMP utamanya digunakan oleh sistem operasi komputer jaringan untuk mengirim pesan kesalahan yang menyatakan, sebagai contoh, bahwa komputer tujuan tidak bisa dijangkau.
POP3 (Post Office Protocol) POP3 (Post Office Protocol) POP3 adalah kepanjangan dari Post Office Protocol version 3, yakni protokol yang digunakan untuk mengambil email dari email server. Protokol POP3 dibuat karena desain dari sistem email yang mengharuskan adanya email server yang menampung email untuk sementara sampai email tersebut diambil oleh penerima yang berhak. Kehadiran email server ini disebabkan kenyataan hanya sebagian kecil dari komputer penerima email yang terus-menerus melakukan koneksi ke jaringan internet.
IMAP (Internet Message Access Protocol)
IMAP (Internet Message Access Protocol) adalah protokol standar untuk mengakses/mengambil e-mail dari server. IMAP memungkinkan pengguna memilih pesan e-mail yang akan ia ambil, membuat folder di server, mencari pesan e-mail tertentu, bahkan menghapus pesan e-mail yang ada. Kemampuan ini jauh lebih baik daripada POP (Post Office Protocol) yang hanya memperbolehkan kita mengambil/download semua pesan yang ada tanpa kecuali.
SMTP (Simple Mail Transfer Protocol)
adalah suatu protokol yang umum digunakan untuk pengiriman surat elektronik atau email di Internet. Protokol ini gunakan untuk mengirimkan data dari komputer pengirim surat elektronik ke server surat elektronik penerima.
Untuk menggunakan SMTP bisa dari Microsoft Outlook. biasanya untuk menggunakan SMTP di perlukan settingan :
1. Email Address : contoh —> anda@domainanda.com 2. Incoming Mail (POP3, IMAP or HTTP) server : mail.doaminanda.com 3. Outgoing (SMTP) server : mail.domainanda.com 4. Account Name : anda@domainanda.com 5. Password : password yang telah anda buat sebelumnya
HTTP (Hypertext Transfer Protocol)
HTTP (Hypertext Transfer Protocol) suatu protokol yang digunakan oleh WWW (World Wide Web). HTTP mendefinisikan bagaimana suatu pesan bisa diformat dan dikirimkan dari server ke client. HTTP juga mengatur aksi-aksi apa saja yang harus dilakukan oleh web server dan juga web browser sebagai respon atas perintah-perintah yang ada pada protokol HTTP ini.
Contohnya bila kita mengetikkan suatu alamat atau URL pada internet browser maka web browser akan mengirimkan perintah HTTP ke web server. Web server kemudian akan menerima perintah ini dan melakukan aktivitas sesuai dengan perintah yang diminta oleh web browser. Hasil aktivitas tadi akan dikirimkan kembali ke web browser untuk ditampilkan kepada kita.
HTTPS https adalah versi aman dari HTTP, protokol komunikasi dari World Wide Web. Ditemukan oleh Netscape Communications Corporation untuk menyediakan autentikasi dan komunikasi tersandi dan penggunaan dalam komersi elektris.
Selain menggunakan komunikasi plain text, HTTPS menyandikan data sesi menggunakan protokol SSL (Secure Socket layer) atau protokol TLS (Transport Layer Security). Kedua protokol tersebut memberikan perlindungan yang memadai dari serangan eavesdroppers, dan man in the middle attacks. Pada umumnya port HTTPS adalah 443.
Tingkat keamanan tergantung pada ketepatan dalam mengimplementasikan pada browser web dan perangkat lunak server dan didukung oleh algorithma penyandian yang aktual.
Oleh karena itu, pada halaman web digunakan HTTPS, dan URL yang digunakan dimulai dengan ‘https://’ bukan dengan ‘http://’
Kesalahpahaman yang sering terjadi pada pengguna kartu kredit di web ialah dengan menganggap HTTPS “sepenuhnya” melindungi transaksi mereka. Sedangkan pada kenyataannya, HTTPS hanya melakukan enkripsi informasi dari kartu mereka antara browser mereka dengan web server yang menerima informasi. Pada web server, informasi kartu mereke secara tipikal tersimpan di database server (terkadang tidak langsung dikirimkan ke pemroses kartu kredit), dan server database inilah yang paling sering menjadi sasaran penyerangan oleh pihak-pihak yang tidak berkepen
SSH (Sucure Shell)
SSH adalah protocol jaringan yang memungkinkan pertukaran data secara aman antara dua komputer. SSH dapat digunakan untuk mengendalikan komputer dari jarak jauh mengirim file, membuat Tunnel yang terrenkripsi dan lain-lain. Protocol ini mempunyai kelebihan disbanding protocol yang sejenis seperti Telnet, FTP, Danrsh, karena SSH memiliki system Otentikasi,Otorisasi, dan ekripsinya sendiri. Dengan begitu keamanan sebuah sesi komunikasi melalui bantuan SSH ini menjadi lebih terjamin. SSH memang lebih aman dibandingkan dengan protocol sejenis, tetapi protocol SSH tatap rentan terhadap beberapa jenis serangan tertentu. Pada umumnya serangan ini ditunjukan Pada SSH versi pertama (SSH-1) yang memang memiliki tingkat keamanan yang lebih lemah daripada SSH versi kedua (SSH-2). Salah satu serangan pada SSH versi pertama adalah serangan MAN IN THE MIDDLE pada saat pertukaran kunci. Protocol SSH serta algoritma yang digunakan pada kedua versi SSH, lalu serangan-serangan yang terjadi pada SSH dan bagaimana SSH mengatasinya. Untuk meningkatkan keamanan pada protocol SSH dapat dilakukan dengan cara menggunakan kartu Kriptografi untuk autentifkasi.Telnet (Telecommunication network) adalah sebuah protokol jaringan yang digunakan di koneksi Internet atau Local Area Network. TELNET dikembangkan pada 1969 dan distandarisasi sebagai IETF STD 8, salah satu standar Internet pertama. TELNET memiliki beberapa keterbatasan yang dianggap sebagai risiko keamanan.
Telnet (Telecommunication network)
Adalah sebuah protokol jaringan yang digunakan di koneksi Internet atau Local Area Network. TELNET dikembangkan pada 1969 dan distandarisasi sebagai IETF STD 8, salah satu standar Internet pertama. TELNET memiliki beberapa keterbatasan yang dianggap sebagai risiko keamanan.
FTP ( File Transfer Protocol )
FTP ( File Transfer Protocol ) adalah sebuah protocol internet yang berjalan di dalam lapisan aplikasi yang merupakan standar untuk pentransferan berkas (file) computer antar mesin-mesin dalam sebuah internetwork. FTP atau protocol Transmission Control Protocol (TCP) untuk komunikasi data antara klien dan server, sehingga diantara kedua komponen tersebut akan dibuatlah sebuah sesi komunikasi sebelum transfer data dimulai. FTP hanya menggunakan metode autentikasi standar, yakni menggunakan User name dan paswordnya yang dikirim dalam bentuk tidak terenkripsi. Pengguana terdaftar dapat menggunakan username dan password-nya untuk mengakses ,men-dawnload ,dan meng- updlot berkas- berkas yang ia kehenaki. Umumnya, para pengguna daftar memiliki akses penuh terdapat berapa direkotri , sehingga mereka dapat berkas , memuat dikotri dan bahkan menghapus berkas. Pengguna yang belum terdaftar dapat juga menggunakan metode anonymous login,yakni dengan menggunakan nama pengguna anonymous & password yang diisi dengan menggunakan alamat e-mail. Sebuah server FTP diakses dengan menggunakan Universal Resource Identifier (URI) dengan menggunakan format ftp://namaserver. Klien FTP dapat menghubungi server FTP dengan membuka URI tersebut.
Tujuan FTP server adalah sebagai beikut : 1. Untuk men-sharing data. 2. Untuk menyediakan indirect atau implicit remote computer. 3. Untuk menyediakan tempat penyimpanan bagi User. 4. Untuk menyediakan tranper data yang reliable dan efisien.
FTP sebenarnya cara yang tidak aman untuk mentransfer file karena file tersebut ditransfesfer tanpa melalui enkripsi terlebih dahulu tapi melalui clear text. Metode text yang dipakai transfer data adalah format ASCII atau format binary. Secara Default, FTP menggunakan metode ASCII untuk transfer data. Karena Pengirimannya tanpa enkripsi, maka username,password,data yang ditransfer maupun perintah yang dikirim dapat dniffing oleh orang dengan menggunakan protocol analyzer (Sniffer). Solusi yang digunakan adalah dengan menggunakan SFTP (SSH FTP) yaitu FTP yang berbasis pada SSH atau menggunakan FTPS (FTP over SSL) sehingga data yang dikirim terlebih dahulu disana.
LDAP LDAP (Lightweight Directory Access Protocol) adalah protokol perangkat lunak untuk memungkinkan semua orang mencari resource organisasi, perorangan dan lainnya, seperti file atau printer di dalam jaringan baik di internet atau intranet. Protokol LDAP membentuk sebuah direktori yang berisi hirarki pohon yang memiliki cabang, mulai dari negara (countries), organisasi, departemen sampai dengan perorangan. Dengan menggunakan LDAP, seseorang dapat mencari informasi mengenai orang lain tanpa mengetahui lokasi orang yang akan dicari itu.
SSL (Secure Socket Layer)
SSL (Secure Socket Layer) adalah arguably internet yang paling banyak digunakan untuk enkripsi. Ditambah lagi, SSL sigunakan tidak hanya keamanan koneksi web, tetapi untuk berbagai aplikasi yang memerlukan enkripsi jaringan end-to-end. Secure Sockets Layer (SSL) merupakan sistem yang digunakan untuk mengenkripsi pengiriman informasi pada internet, sehingga data dapat dikirim dengan aman. Protokol SSL mengatur keamanan dan integritas menggunakan enkripsi, autentikasi, dan kode autentikasi pesan. SSL protocol menyedian privasi komunikasi di internet. SSL tidak mendukung fileencryption, access-control, atau proteksi virus, jadi SSL tidak dapat membantu mengatur data sensitif setelah dan sebelum pengiriman yang aman. Protokol SSL terdiri dari dua sub-protokol: SSL record protocol dan SSL handshake protocol. SSL record protocol mendefinisikan format yang digunakan untuk mentransmisikan data. Sedangkan SSL handshake protocol melibatkan SSL record protocol untuk menukarkan serangkaian pesan antara SSL enabled server dan SSL enable client ketika keduanya pertama kali melakukan koneksi SSL. Pertukaran pesan tersebut digunakan untuk memfasilitasi tindakan sebagai berikut : • Autentikasi dari server ke klien • Mengizinkan klien dan server untuk memilih algoritma kriptografi atau sandi, yang mendukung komunikasi keduanya. • Autentikasi dari klien ke server. • Menggunakan teknik enkripsi public key untuk membuka data yang dienkripsi • Membuat enkripsi koneksi SSL
C. OSI Model
Open Systems Interconnection (OSI) model adalah suatu referensi untuk memahami komunikasi data antara dua buah sistem yang saling terhubung. OSI layer membagi proses komunikasi menjadi tujuh lapisan. Setiap lapisan berfungsi untuk melakukan fungsi-fungsi spesifik untuk mendukung lapisan diatasnya dan sekaligus juga menawarkan layanan untuk lapisan yang ada di bawahnya. Tiga lapisan terbawah akan fokus pada melewatkan trafik melalui jaringan kepada suatu sistem yang terakhir.
Empat lapisan teratas akan bermain pada sistem terakhir untuk menyelesaikan proses komunikasinya.
Pembagian tersebut memiliki kelebihan sebagai berikut:
Membuat komunikasi jaringan ke bagian yang lebih sederhana.
Membuat standard untuk komponen jaringan yang memungkinkan pengembangan dan dukungan multiple-vendor. Memungkinkan hardware dan software jaringan yang berbeda untuk berkomunikasi satu dengan yang lain.
Mencegah efek perubahan dalam sebuah layer mempengaruhi layer yang lain,sehingga dapat perkembangan lebih cepat.
Model OSI di buat untuk mengatasi berbagai kendala Internetworking akibat perbedaan arsitektur dan protokol jaringan. Dahulu, komunikasi antar komputer dari vendor yang berbeda sangat sulit dilakukan. Masing-masing vendor menggunakan protokol dan format data yang berbeda-beda. Sehingga International Organization for Standardization (ISO) membuat suatu arsitektur komunikasi yang di kenal sebagai Open System Interconection (OSI) model yang mendefinisikan standar untuk menghubungkan komputer-komputer dari vendor yang berbeda.
OSI Reference Model :
GAMBAR: Bagan OSI Reference Model
Dibawah ini dapat dijelaskan tentang bagaimana yang dikemukakan bagan diatas :
Application layer Berfungsi sebagai antarmuka dengan aplikasi dengan fungsionalitas jaringan, mengatur bagaimana aplikasi dapat mengakses jaringan, dan kemudian membuat pesan-pesan kesalahan. Protokol yang berada dalam lapisan ini adalah HTTP, FTP, SMTP, dan NFS.
Presentation layer Berfungsi untuk mentranslasikan data yang hendak ditransmisikan oleh aplikasi ke dalam format yang dapat ditransmisikan melalui jaringan. Protokol yang berada dalam level ini adalah perangkat lunak redirektor (redirector software), seperti layanan Workstation (dalam Windows NT) dan juga Network shell (semacam Virtual Network Computing (VNC) atau Remote Desktop Protocol (RDP)).
Session layer Berfungsi untuk mendefinisikan bagaimana koneksi dapat dibuat, dipelihara, atau dihancurkan. Selain itu, di level ini juga dilakukan resolusi nama.
Transport layer Berfungsi untuk memecah data ke dalam paket-paket data serta memberikan nomor urut ke paket-paket tersebut sehingga dapat disusun kembali pada sisi tujuan setelah diterima. Selain itu, pada level ini juga membuat sebuah tanda bahwa paket diterima dengan sukses (acknowledgement), dan mentransmisikan ulang terhadp paket-paket yang hilang di tengah jalan.
Network layer Berfungsi untuk mendefinisikan alamat-alamat IP, membuat header untuk paket-paket, dan kemudian melakukan routing melalui internetworking dengan menggunakan router dan switch layer-3.
Data-link layer Befungsi untuk menentukan bagaimana bit-bit data dikelompokkan menjadi format yang disebut sebagai frame. Selain itu, pada level ini terjadi koreksi kesalahan, flow control, pengalamatan perangkat keras (seperti halnya Media Access Control Address (MAC Address)), dan menetukan bagaimana perangkat-perangkat jaringan seperti hub, bridge, repeater, dan switch layer 2 beroperasi. Spesifikasi IEEE 802, membagi level ini menjadi dua level anak, yaitu lapisan Logical Link Control (LLC) dan lapisan Media Access Control (MAC).
Physical layer Berfungsi untuk mendefinisikan media transmisi jaringan, metode pensinyalan, sinkronisasi bit, arsitektur jaringan (seperti halnya Ethernet atau Token Ring), topologi jaringan dan pengabelan. Selain itu, level ini juga mendefinisikan bagaimana Network Interface Card (NIC) dapat berinteraksi dengan media kabel atau radio.
D. TCP/IP
Transmission Control Protocol/Internet Protocol (TCP/IP) adalah satu set aturan standar komunikasi data yang digunakan dalam proses transfer data dari satu komputer ke komputer lain di jaringan komputer tanpa melihat perbedaan jenis hardware. Protokol TCP/IP dikembangkan dalam riset pertama kali oleh Defense Advanced Research Projects Agency (DARPA) di Amerika Serikat dan paling banyak digunakan saat ini yang implementasinya dalam bentuk perangkat lunak (software) di system operasi. Protokol TCP/IP dikembangkan dalam riset pertama kali oleh Defense Advanced Research Projects Agency (DARPA) di Amerika Serikat dan paling banyak digunakan saat ini yang implementasinya dalam bentuk perangkat lunak (software) di system operasi.
CP/IP Layers terlihat seperti gambar dibawah ini :
• Application
• Transport
• Internet
• Network Interface
Arsitektur TCP/IP tidaklah berbasis model referensi tujuh lapis OSI, tetapi menggunakan model referensi DARPA. Seperti diperlihatkan pada gambar, TCP/IP merngimplemenasikan arsitektur berlapis yang terdiri atas empat lapis. Empat lapis ini, dapat dipetakan (meski tidak secara langsung) terhadap model referensi OSI. Empat lapis ini, kadang-kadang disebut sebagai DARPA Model, Internet Model, atau DoD Model, mengingat TCP/IP merupakan protokol yang awalnya dikembangkan dari proyek ARPANET yang dimulai oleh Departemen Pertahanan Amerika Serikat.Setiap lapisan yang dimiliki oleh kumpulan protokol (protocol suite) TCP/IP diasosiasikan dengan protokolnya masing-masing. Protokol utama dalam protokol TCP/IP adalah sebagai berikut:
Application Layer
Bertanggung jawab untuk menampilkan semua aplikasi yang menggunakan protocol TCP/IP. Sebagai contoh adalah Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), dan Telnet.
Transport Layer
Bertanggung jawab untuk mengadakan komunikasi antara dua host/komputer. Ada dua macam protokol didalamnya, yaitu Transmission Control Protocol (TCP) dan User Datagram Protocol (UDP ).
Internet Layer
Bertanggung jawab untuk melakukan pemetaan (routing) dan enkapsulasi paket-paket data jaringan menjadi paket-paket IP. Protokol yang bekerja dalam lapisan ini adalah Internet Protocol (IP), Address Resolution Protocol (ARP), Internet Control Message Protocol (ICMP), dan Internet Group Management Protocol (IGMP).
Network Interface
Bertanggung jawab untuk meletakkan frame-frame jaringan di atas media jaringan yang digunakan. TCP/IP dapat bekerja dengan banyak teknologi transport, mulai dari teknologi transport dalam LAN (seperti halnya Ethernet dan Token Ring), MAN dan WAN (seperti halnya dial-up modem yang berjalan di atas Public Switched Telephone Network (PSTN), Integrated Services Digital Network (ISDN), serta Asynchronous Transfer Mode (ATM)).
E. Layanan
Berikut ini adalah layanan tradisional yang dapat berjalan di atas protokol TCP/IP:
• Pengiriman berkas (file transfer). File Transfer Protocol (FTP) memungkinkan pengguna komputer yang satu untuk dapat mengirim ataupun menerima berkas ke sebuah host di dalam jaringan. Metode otentikasi yang digunakannya adalah penggunaan nama pengguna (user name) dan [[password]], meskipun banyak juga FTP yang dapat diakses secara anonim (anonymous), alias tidak berpassword. (Keterangan lebih lanjut mengenai FTP dapat dilihat pada RFC 959.)
• Remote login. Network terminal Protocol (telnet) memungkinkan pengguna komputer dapat melakukan log in ke dalam suatu komputer di dalam suatu jaringan secara jarak jauh. Jadi hal ini berarti bahwa pengguna menggunakan komputernya sebagai perpanjangan tangan dari komputer jaringan tersebut. (Keterangan lebih lanjut mengenai Telnet dapat dilihat pada RFC 854 dan RFC 855.)
• Computer mail. Digunakan untuk menerapkan sistem surat elektronik. (Keterangan lebih lanjut mengenai e-mail dapat dilihat pada RFC 821 RFC 822.)
• Network File System (NFS). Pelayanan akses berkas-berkas yang dapat diakses dari jarak jauh yang memungkinkan klien-klien untuk mengakses berkas pada komputer jaringan, seolah-olah berkas tersebut disimpan secara lokal. (Keterangan lebih lanjut mengenai NFS dapat dilihat RFC 1001 dan RFC 1002.)
• Remote execution. Memungkinkan pengguna komputer untuk menjalankan suatu program tertentu di dalam komputer yang berbeda. Biasanya berguna jika pengguna menggunakan komputer yang terbatas, sedangkan ia memerlukan sumber yg banyak dalam suatu sistem komputer. Ada beberapa jenis remote execution, ada yang berupa perintah-perintah dasar saja, yaitu yang dapat dijalankan dalam system komputer yang sama dan ada pula yg menggunakan sistem Remote Procedure Call (RPC), yang memungkinkan program untuk memanggil subrutin yang akan dijalankan di sistem komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah rsh dan rexec.)
• Name server yang berguna sebagai penyimpanan basis data nama host yang digunakan pada Internet (Keterangan lebih lanjut dapat dilihat pada RFC 822 dan RFC 823 yang menjelaskan mengenai penggunaan protokol name server yang bertujuan untuk menentukan nama host di Internet.)
PENUTUP
A. Kesimpulan
Setelah menyelesaikan penulisan makalah ini, penulis dapat menyimpulkan beberapa hal, antara lain :
Pemahaman terhadap teori dasar tentang jaringan computer, khususnya pada protocol jaringan, sangat diperlukan guna kelancaran dalam praktek jaringan computer.
Secara umum protocol mempunyai fungsi untuk menghubungkan sisi pengirim dan penerima dalam berkomunikasi serta bertukar informasi.
B. Saran
Melihat dari penjelasan diatas maka penulis menyarankan agar kira dalam pelajan TIK dibangku perkuliahahn dapat ditingkatkan dengan memberikan materi penggunaan dan penghubungan system jaringan dengan Komputer, Komunikasi antar Komputer dalam hal ini seperti yang kita ketahui bahwa penggunaan jaringan social seperti Facebook, Twitter, Blogger, Wordpres, Dll sudah marak dizaman sekarang ini jadi untuk itu dapat diterapka dibangku perkuliahan cara berkomunikasi melalui media Internet.
DAFTAR PUSTAKA
Sofana,iwan.(2008).”Membangun Jaringan Komputer”, Penerbit Informatika, Bandung
http://id.wikipedia.org/wiki/Transmission_Control_Protocol/Internet_Protocol
http://www.ittelkom.ac.id/library/index.php?option=com_content&view=article&id=69:dasar-tcpip&catid=6:internet&Itemid=15
http://one.indoskripsi.com/node/6594uyuhugyy
Langganan:
Posting Komentar (Atom)
Tidak ada komentar:
Posting Komentar